Enable Java in Firefox Ubuntu

I’ve been trying to get Java applet working to be able to remotely access my UCL desktop through Oracle Secure Global Desktop Web Server

Googling around seems to get me to the answer that it is not possible to get it working with Chrome as it has changed its policy. However, it’s possible with Firefox

Instructions on Java website aren’t helping at all

Here’s how I made it to work:
http://askubuntu.com/questions/354361/how-to-install-the-java-plugin-for-firefox

sudo apt-get install icedtea-plugin

then go to about:addons

You should have IcedTea-Web Plugin (using IcedTea-Web 1.5 (1.5-1ubuntu1)) on the plugin list and it’s not enable

Change it to Always Active and restart browser
It should work fine now 🙂

Make changes to SensorTag

1. Cloud http://dev.ti.com/tirex/#/?link=CC26xx%20Bluetooth%20Smart%2FDevelopment%20Tools%2FCC2650%20Bluetooth%20Smart%20SensorTag%2FExamples%2FSensorTag
2. Code Composer Studio – debug, then make sure to click Resume otherwise, it won’t be detected on the SensorTag app on the phone

Also, the example https://www.youtube.com/watch?v=Ag4EDXVZ7HQ to change the name etc; the file has changed location to SensorTag>Application>SensorTag.c

// Device information parameters
static const uint8_t devInfoModelNumber[] = "Adila SensorTag";
static const uint8_t devInfoNA[] = "N.A.";
static const uint8_t devInfoFirmwareRev[] = FW_VERSION_STR;
static const uint8_t devInfoMfrName[] = "Texas Instruments";
static const uint8_t devInfoHardwareRev[] = "PCB 1.2/1.3";

for Cloud, need to install
1. TI Cloud Agent
2. Modify proxy at where you installed in at C:\Users\noradila\TICloudAgent\util\proxy.js

add:
module.exports.proxy = "DIRECT"

Setup CC2650 Sensortag

I had way too much problem getting it to work. Finally it’s working!
I’m using CC2650 sensortag with debugger devPack
Make sure the sensor is being detected in Device Manager otherwise it won’t work
If it is not being detected, check if the LED are light up
If they are, change to other cables – cables that you use to charge the phone might not work (at least that was the problem with mine – 3 of my cables aren’t working with the sensor but work for charging phones)

The one that worked was LOGIK 1.2m micro USB cable (USB A to micro USB) I got it for £19.99 (I think!) from PC World

Here’s the link where I followed how setup http://43oh.com/2015/07/how-to-setup-a-development-environment-for-the-cc2650stk-sensortag/

1. Install BLE-STACK2
2. Install Code Composer Studio
Help->CCS App Center> update TI-RTOS for SimpleLink
and TI-ARM compiler

3. Install XDS emulation

Open CCS, select a workspace
File->TI Resource Explorer. On the left panel you should see BLE-Stack for SimpleLink wireless MCUs
If you don’t see it, click Add additional packages and look for it at C:\ti\simplelink\ble_cc26xx_2_01_00_4423 (or where you installed BLE-STACK2 at)
Add that package; go through ble_cc26xx_2_01_00_4423>Projects>ble>SensorTag>CC26xx>CCS and you’ll find SensorTag and SensorTagStack

Import SensorTag and SensorTagStack
Build SensorTagStack

Plug in the sensor and debug

Good to go! 😀